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Using the
CaseMgr Calendar

Calendar Screen - Day Tab

The Calendar is a  module of De Novo
CaseMgr. Reach it from the Tools Menu, or
with the Command-L key combo. The Personal
Settings option of the Edit Menu offers an
option to open the Calendar Screen on start-

ing CaseMgr. The
Calendar Screen
is internally tabbed,
with four tab win-
dows appearing in
the lower part of the
screen. Today’s date
and the Day Tab is
the default when
you initially arrive
at the Calendar
Screen. Select a
different view of the
Calendar by clicking
the Week, Month or
List Tab. On later
visits, the last Tab

set on the screen is the default. The top por-
tion of the screen applies to all four tabs, and
always shows a “Go to date” control for select-
ing the starting date of the window display, a
Show control with a Pop-up for selecting a user
or group of users, a client or a matter, check-
boxes to show or hide weekend dates, completed
tasks and checklist items, and New Appoint-
ment and New Task buttons. The whole win-
dow can be resized by (on Windows) dragging
from any side or (on Macintosh) by dragging the
lower right corner of the window.

You may directly enter a date in the Go To Date
field, or click the small calendar icon to the right
of the field to display the Pop-up Date-Picker
window. When the cursor is within this window,
one date is always highlighted. Move the cursor
to highlight the desired start date and click the
mouse to select that date.  Note that the
CaseMgr Date Calculator function is built into

Today’s Tasks
(To-do items)

Today’s
appointments

Pop-up Date-Picker Window
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Show Pop-up List

every date field. Just type in the calculation. For
example “Today + 3 Months” or “TOD + 45 DY”.
Clicking the Today button to the right of the Go
to date field takes you to the current date. You
should confirm that the correct date is set on your
computer’s Date/Time (Windows) or Date &
Time (Macintosh) control panel.

The Show Pop-up list allows you to display
appointments and tasks for everyone, or only
those appointments or tasks associated with a
selected user or group of users, or with a particu-
lar client or matter. The default behavior is to
display all items associated with the current user.

There are three checkboxes beneath the Pop-up
list: Weekends, Completed Tasks, and Matter
Checklist Items. Weekends  toggles (turns on or
off) the display of Saturday and Sunday appoint-
ments and tasks. Completed tasks toggles the
display of task items which are marked as com-
pleted with a mark in the checkbox to the left of
the item. Matter Checklist Items toggles the dis-
play of Checklist Items, a special category of Tasks
which are created using the Matter Screen’s
Checklist tab. New appointments and new tasks

can always be added
using the buttons in the
upper right corner of the
screen.

On the Calendar Day
Tab, the left side shows
this date’s Appoint-
ments, and the right
side lists the Tasks, or
to-do items, for the day.
Just below the Day tab
itself, there are two
small controls, a left
(Back) and right (For-
ward) arrowhead. These

change the display by one unit, with the unit

Day Tab

Drag handle
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selected by the tab. When the selected tab is the
Day tab, the unit changed is a single day. When
the Month tab is the active tab, they would
move the display to the next or the previous
month. The chosen date always shows to the
right of these controls.

The relative size of the two panels can be
changed by dragging the bar between the two
panels to the left or right to allow more space for
Appointments or Tasks. Scroll either side using
the vertical scrollbars. You can add a new ap-
pointment to the left side Appointments list by
clicking and dragging the mouse cursor to out-
line the area corresponding to the time of the
appointment you wish to create, or by simply
double-clicking in the Appointments area.

The Calendar Week Tab gives a broader view
of your tasks and appointments. View a single

week, with or without
Saturdays and Sundays.
Tasks are viewed in the
panel below the Weekly
Appointments panel, and
the relative size of the
Weekly Appointments
and the Tasks panels
may be changed by
dragging the handle on
the bar separating them.
As on the Day Tab, you
can add appointments by
either clicking the New
Appointment button or
by using the mouse to
click and drag, enclosing
the area of the appoint-
ment you wish to set.

The drag area must be completely within a
single day. (Recurring appointments are indi-
cated on the New Appointment window, which
opens after the drag selection is completed.)

Week Tab

Drag handle
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Tasks (other than Checklist items, added from
the Matter Checklist Tab) are always added
using the New Task button.

The Calendar Month Tab displays a full
month of information at a glance, and it can be

filtered to show information for
all users or a particular Group or
User (all Attorneys for the firm
are  entered as Users, even if
they never personally access
CaseMgr), or for a particular
Client or Matter. Weekend dates,
completed tasks and checklist
items can each be hidden or
displayed.

Because each day’s area is quite
small in the Month view of the
information, only very little
identifying information is offered
in this view. You will want to use

other tabs to see details. Appointments, which
necessarily have both starting and ending times,
begin with the starting time, and only part of
one line is displayed. Lines do not wrap. Tasks,
which may have a Deadline date and time, are
displayed following a bullet on the deadline date
and thereafter until checked as completed.

Again, only a single line appears
for each Task. Double-click an
item, either an Appointment or a
Task, to edit it.

The Calendar List Tab offers a
view of your calendar items as a
list, much like those offered from
the Lists Menu. All the usual
calendar item filtering and date
selection is available, but in
addition you can sort items by
clicking on the column headings,
and you may insert additional
calendar-related columns. The

List Tab

Calendar Month Tab

Month Tab
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selection of displayed columns is remembered
and becomes the new default display on a user-
by-user basis.

Because the list can become quite cluttered with
the tasks and appointments of multiple users,
particularly when checklist items are visible,
the list tab will be most useful when appropriate
filters are set.

Appointments are associated with a starting
and ending time. Tasks, or to-dos are associated
with a Deadline date (and, optionally, a time)
only. Both Tasks and Appointments may be
directly entered into the Calendar, and are in
some cases automatically posted to the calendar
when a date is saved on a CaseMgr screen. To
directly enter a new Appointment:

1.  Choose New Record from the File Menu and
set the record type to “Appoint-
ment”. Alternatively, you may
open the Calendar by clicking
the Calendar button on the Main
Screen, or by selecting the Calen-
dar item from the Tools Menu,
or pressing CTRL-L.

2. Click the New Appointment
button located at the upper right
of the screen or, in the Appoint-
ment (left) side of the Calendar
Screen Day Tab, click and drag
the cursor to enclose the approxi-
mate area  corresponding to the
duration of the appointment (or
simply double-click). On the Week
Tab, click and drag the cursor to
enclose the approximate area

corresponding to the duration of the appoint-
ment, staying within the column of the ap-

Appointments &
Scheduled Events

New Appointments Screen
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pointed day (or simply double-click). On the
Month Tab, double-click on the appointed day.
Finally, you can select New Appointment from
the contextual (right-click) menu while in the
Calendar

3. After the New Appointment screen appears,
enter the following:
• Description of the Appointment (required)
• Category (Pop-up list)
• Beginning and Ending times (required.)
 • User/Group; defaults to the current user

(required.)
 • Matter (Pop-up list)
 • Client (Pop-up list)
 • Recurring appointment checkbox. When

checked, the following new controls appear:
 • Recur When (Pop-up list)
    The items in this list are self-evident with

the possible exception of “User nearest date
in short months.” Use this item for Monthly
dates which don’t appear in every month,
like the 30th day, which will not appear in
February. This option would move the
monthly appointment to the nearest Febru-
ary day, normally the 28th.

 • Recur until, the termination date for the
recurring appointment

 • Total Appts. When the Recur Until date is
entered, this field shows how many appoint-
ments your entry creates. You may enter a
number directly into this field and it will
change the Recur until date as required to
create the number of recurrences entered
using the period specified in the Recur When
Pop-up list.

• Remind me of this appointment checkbox
When this box is checked, the following new
controls appear:

• Remind…before, a field in which to enter a
numeral, followed by a Period Pop-up, for
Minutes, Days or Hours. These control the
Pop-up reminder windows. You might indicate
that you want to be notified via a Pop-up on-

Recur When Pop-up
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screen reminder that an appointment is
scheduled for 1:30 PM on Aug. 24, and that
you want the reminder to appear 1 hour be-
fore the appointment.

4. Click the Save and Close button to save the
Appointment, or the Cancel button to discard
your entry.

Tasks are to-do items,
goals which may have a
Category, optionally a
Deadline date and time, and
a Priority (high, normal or
low). They may be marked
as completed when appro-
priate, which removes
them from the Calendar
screens (unless the Show
completed items checkbox
is marked) and they may
be marked to Carry Over.
When marked as Carry
Over items, they appear
again on the date following
the Deadline date and
continue to do so until
marked as Completed. Items
without a deadline date carry

over automatically.

Tasks may be associated with a Client and
Matter, and they may be marked as Private,
which makes them visible to just the User or
Group to which they have been assigned. The
default assignment for User/Group is to the
user entering the new Task. They may also be
assigned to All Users.

If a Deadline date has been assigned, Tasks
may be marked as Recurring tasks, which
makes them appear on a scheduled basis until
a specific date.

Tasks (To-dos)

New Tasks Screen
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Finally, if a task has a Deadline Date, reminders
may be scheduled at a specified period before the
deadline. To directly enter a new Task:

1.   Choose New Record from the File Menu and
set the record type to “Task”. Alternatively, you
may  open the Calendar by clicking the Calen-
dar button on the Main Screen, or by selecting
the Calendar item from the Tools Menu, or
pressing CTRL-L.

2. In the Calendar, click the New Task button
located at the upper right of the screen or select
New Task from the contextual (right-click) menu

while in the Calendar

3. After the New Task
screen appears, enter the
following information:
• Description of the Task
(required)
• Category (Pop-up list)
• Deadline date and Time
• User/Group; defaults to
the current user and may
also be “All” (required.)
 • Matter (Pop-up list)
 • Client (Pop-up list)
 • Recurring task checkbox.
When checked, the follow-
ing new controls appear:
 • Recur When (Pop-up list)
 • Recur until; the termi-
nation date for the recur-
ring task

 • Total tasks When the Recur Until date is
entered, this field shows how many tasks
your entry creates. You may enter a number
directly into this field and it will change the
Recur until date as required to create the
number of recurrences entered.

• Remind me of this task checkbox. When
checked, the following new controls appear:

New Tasks Screen
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• Remind…before, a field in which to enter a
numeral, followed by a Period Pop-up, for
Minutes, Days or Hours. These control the
Pop-up reminder windows.

For Appointments and for Tasks which have
deadline dates, Reminders
may be set which, if CaseMgr is
open, will pop up, beep and let
the designated user know that
the time has come to take
action

Reminders can be set for a
particular User or Group of
users, or for All Users. In any
case, just the user or group
selected will see the reminder

when the appointed date and time arrives.
Remember that CaseMgr must be running and
the user must be logged into the program for the
reminder to appear. If CaseMgr is not running,
or the user is not logged in, the user will not
receive the reminder.

When the reminder
appears on the screen,
the user may close it
without reading, using
the close box, or read it,
using the Read Button.
The detail window dis-
played by the Read
button offers the option
to dismiss the reminder
with the OK button, or to
see it again later, using
the text box after “in” to
enter a number and the
pop-up button to set that

number to minutes, hours or days of delay
before the reminder returns.

Reminders (Nags)

Reminder Screen

Reminder Detail Screen


